Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have a basic question, I am new here AmiKit Support Forum / I have a basic question, I am new here /

Very slow performance

Author Anonymous
Guest
#1 Posted: 10 May 2006 01:22 
I installed Amikit for the first time. I just received my copy of OS3.9 so was very keen to give it a go. I installed Amikit 1.1.1 and it worked perfectly. After I had rebooted my PC the next day, I launched Amikit and it was running extremely slow. I pushed the F12 key and it showed WinUAE 1.2. I had a previously installed copy of UAE. I therefore completely uninstalled Amikit and then uninstalled Winuae 1.2, deleted the configurations from Winuae. Bear in mind that Amikit was installed to a different location and that it had it's own configs but when I keyed F12 it came up with the Winuae 1.2 interface.

Anyway, I reinstalled freshly. Amikit then seemed to load faster but once the virtual OS3.9 desktop loaded Amikit would work for 2-3 secs and then just freeze (but not the mouse pointer). I would then key F12, then click cancel and Amikit would work for about another 3 secs, and then freeze or at least come to a crawl. It seems by only keying F12 to the main UAE interface and then back to Amikit would make Amikit work normal for about the 3 secs.

Maybe I have done something fundlementally wrong and it seemed to be working fine after the first install. I updated to Amikit 1.1.2 but no difference. I don't think there are any services under Windoze that might be interferring?

Any advice?

Author Robert
Guest
#2 Posted: 10 May 2006 01:53 
Update:

I read through the forums and apparently this can be caused by a crashing IPrefs during the boot process. If I presee ESC during the boot process nothing happens. The thing is I get past the CAT picture if I press F12 and continuously go back and forth from the UAE interface back to Amikit, as explained before.

The other possible cause is to remove ShowAmiga96 from startup-sequence. I am familiar with the directory structure of an Amiga but but not sure how to edit the startup when using Amikit especially when Amikit is running so slow.

Also, how do I use Amikit/S/Startup-Sequence.SAFEMODE. THis was another suggestion.

I also noticed when I went to UAE, it was set to 020 emulation only and it appeared to loose the loaction of the KS3.1 ROM. I then manually set UAE to 040 and the location of the KS.

Author Nightbreed
Registered
#3 Posted: 10 May 2006 05:05 
To use startup-sequence.safemode, just copy that to the S folder and rename it to startup-sequence

Author Robert
Guest
#4 Posted: 10 May 2006 05:57 
Within Windows Explorer? It would be very hard to do within the Amikit session since it is not responding.

Sorry if that was a silly question :)

Author Anonymous
Guest
#5 Posted: 10 May 2006 17:05 
Yeah, usually, before I created an emergency boot floppy image for Amiga I used explorer for file manipulation. But I would suggest creating or finding a basic workbench boot fd0 image too boot from. I also have a minimal HD image of AmigaOS that gives me application functions without all the extra bells and whistles, just incase the Amiga doesn't want to work right.

So, yeah, for now... Just use explorer ;)

Author Nightbreed
Registered
#6 Posted: 10 May 2006 17:06 
Opps sorry for not logging in :)

Author AmiKit
Admin
#7 Posted: 10 May 2006 19:27 
Hello!

AmiKit package contains WinUAE 1.1.2 in its own directory so it is not needed to instal WinUAE at all if you use AmiKit only.

Slowdown is sometimes cuased by WinUAE itself. Simply it starts in very slow manner sometimes. Just quit the emulation and try to start it again.

Slowdown of WinUAE (and other software ofcourse) could also be caused by spyware. Try to check your computer for spyware by running eg. SpyBot ? Search&Destroy.

Someone also reported the huge slowdown on 64bit CPUs however I cannot test it because I do not have such a CPU.

To run AmiKit in SAFEMODE (where all the additional and unofficial patches are disabled) just go to AmiKit\S directory (at PC side). Rename Startup-Sequence to Startup-Sequence.backup and then rename Startup-Sequence.SAFEMODE to Startup-Sequence. Then run AmiKit.

To edit Startup-Sequence (from AmiKit side) just use the taskbar -> Tools -> System -> Startup-Sequence. The error message appears when you save the changes but you can ignore it. The changes are saved anyway. This is the bug of microgolded (or WinUAE filesystem emulation).

The ROM path is set to relative location, it's something like "..ROMs\kick.rom". This ensures the ROM is alwys found regardless the location of installed AmiKit.

Yes, 020 emulation is set as default. This is because of better compatibility. There's not much speed-up if you set it to 040.

IPrefs crashing is already solved in 1.1.1 release of AmiKit thanks to implementation of AfA_OS.

Author Robert
Guest
#8 Posted: 11 May 2006 01:17 
Weird thing. I reinstalled Amikit for the 4th time after another PC reboot and voila, it is working sweet. Can't figure it. My PC has Spybot installed but it's not running any service and I made no changes to the PC. UAE experienced no slow down when running custom configs. Anyway, it's working sweet, Boing bags installed and all :)

Got some WHDload games going to test out speed and that was just fine too. Very happy with it.

Thanks for a cool Ami Distro. It rawks.

I have a basic question, I am new here AmiKit Support Forum / I have a basic question, I am new here / Very slow performance Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 5
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0