AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 287 [27 Apr 2018 00:59]
Guests - 287 / Members - 0
Mac related questions AmiKit Support Forum / Mac related questions /  
 

Mac - program not responding

 
Author amikit_noob
Partaker
#1 Posted: 19 Aug 2018 09:09 Edited by: amikit_noob 
Specs: AmiKitX 10.5, OS3.9 OSXL as source, 1680x1050 fullwindow 32bit, iMac early 2009, 2.66GHz, 4 GB Ram, macOS High Sierra 10.13.6.
-----------------------------------------------------
Hi, suddenly AmiKit will not open/start, now I get this error on mac every time : "Program not responding" ?

I open AmiKitX by leftclicking once on AmiKit logo (in Applications folder on mac) while holding down the Ctrl key, then I choose Open in the menu. This always opens AmikitX Launch window, but now it tries to load and then gives the error ?

Any advice on why the mac version suddenly gives this error, I have not changed anything on the mac.

(Only thing that helps is to reinstall xquartz and amikitx from scratch, then then Launch window will load and amikitx will boot, but only until next reboot of the mac, then I get a "Program not responding" error)

Thanks
amikit_noob

Author AmiKit
Admin
#2 Posted: 19 Aug 2018 12:47 
I recommend to back up AmiKit.hdf, delete AmiKit from Applications, re-install it and copy the AmiKit.hdf back. This way everything should be set to default plus you still have your hdf.

Author amikit_noob
Partaker
#3 Posted: 31 Aug 2018 10:15 
When I search for amikit.hdf or .hdf on the mac, nothing is found, so I don't know where the .hdf file is on the mac version ?

amikit_noob

Author AmiKit
Admin
#4 Posted: 31 Aug 2018 10:18 
Press right-mouse button over the AmiKit app and select "Show Package Contents". Then navigate to the following folder: Contents > MacOS > AmiKit > drive_c > AmiKit > AmiKit

Author amikit_noob
Partaker
#5 Posted: 31 Aug 2018 10:40 
Yes, I found it, thanks

Author amikit_noob
Partaker
#6 Posted: 31 Aug 2018 12:52 Edited by: amikit_noob 
I re-installed amikitx, following the guide, but the "program not responding" error still happens on a fresh new AmiKitX, the first time AmiKit is trying to open the "Launch window/program".

It just hangs, but if I Quit the AmiKit program, then Wine will load and update, and after that the "Launch window/program" will load.

Then AmiKitx will boot and update and work just fine.

So it seems, that on mac, the "program not responding" error is because AmiKit is waiting for Wine to load/update (at least the first time), before Amikit can continue ?

Author AmiKit
Admin
#7 Posted: 31 Aug 2018 12:59 Edited by: AmiKit 
Not sure what's happening there, especially if it worked before.

Maybe try to update Wine manually according to the instructions in Quick Guide

Author amikit_noob
Partaker
#8 Posted: 31 Aug 2018 13:26 
I updated Wine, following the guide, now there is no error, and Launch window/program loads faster.
So for now it works

Thanks
amikit_noob

Author amikit_noob
Partaker
#9 Posted: 4 Sep 2018 11:25 Edited by: amikit_noob 
Well, now the error is back, AmiKitX refuses to open the "Launch window/program", and shows "Program not responding".

I reinstalled everything according to the guide (xquartz and amikit) , updated wine again, rebooted the mac, but no luck this time...

I cant get it to open the Launch window so I can begin the amigaos installation...

I also tried to delete/replace .plist files / preferences, since this could be the problem, but that does not help at all....
I "Force quit" wine and wineserver and amikitx in the "Activity Monitor", and restarted AmiKitX, but it just hangs,

then gives the error, and wine /Launch window DOES NOT LOAD ....

I am really out of ideas by now, dont know why it just stopped working...

Author AmiKit
Admin
#10 Posted: 4 Sep 2018 19:38 
Well, something strange is happening on your Mac... I am running out of ideas. Is there any wine or .wine folder on your Mac?

Author amikit_noob
Partaker
#11 Posted: 4 Sep 2018 20:29 
Yes, I have the wine folder located at
Applications>AmiKitX>Contents>MacOS>wine

I'm not sure if I have a .wine folder

Author AmiKit
Admin
#12 Posted: 4 Sep 2018 21:25 Edited by: AmiKit 
I mean try to uninstall Wine completely https://apple.stackexchange.com/questions/267736/how-do-i-uninstall-wine
Uninstall XQuartz too. https://www.uninstallmacapp.com/xquartz-x11-removal.html

Maybe you can use some deeper uninstaller? I use paid version of Dr.Cleaner Pro (not sure if free version can deeply uninstall too).

And then re-install Quartz 2.7.9 (make sure not to update it), re-install AmiKit, import ROM, update WinUAE and wine. And if it works, backup your AmiKit app immediately.

Author amikit_noob
Partaker
#13 Posted: 9 Sep 2018 17:25 
Thanks for the links/tips, I got AmiKitX working again by following all the steps to manually remove wine / xquartz files.

I have backed up amikitx app like you suggested.

So AmiKitX boots and works

BUT the first time (after fresh new install) I start AmiKitX, I still get this error "program not responding" and ONLY after Quitting AmiKitX, then Wine will load (Wine says it is is updating) and Launch window is then loaded and I can boot into AmiKitx.

So I got it to work with your help, but I still get the error sometimes, and that is what I dont understand ...

Author AmiKit
Admin
#14 Posted: 9 Sep 2018 17:44 
I am happy it works for you again. And sorry I could not help more. It's hard to troubleshoot something if I cannot reproduce it here.

Mac related questions AmiKit Support Forum / Mac related questions /
 Mac - program not responding

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ TOP