Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have Mac specific question AmiKit Support Forum / I have Mac specific question /

MAC Flower Pot - RunInUAE installer crashing

Author Ladjets
Registered
#1 Posted: 25 Feb 2017 23:46 
Hi

Im trying to install RunInUAE, as soon as it asks about WHDload key the Grim Reaper appears.

Guru Meditation: 80000003
Task 0x3e6e6930 ("C/GfxChip)

Imac Late 2012 - Sierra 10.12.4

Any thoughts ?

Thanks
Mattie

Author AmiKit
Admin
#2 Posted: 26 Feb 2017 18:30 
Hi Mattie,

unfortunately this out of my area of expertise. This forum covers AmiKit and FlowerPot themselves, while RunInUAE is a program made by Chris Handley. Please contact him directly check the program manual. Or try some forums discussing OS4 software, for example: www.amigans.net or www.amigaworld.net

Thanks for understanding.
Jan

Author GeoKM
Registered
#3 Posted: 27 Apr 2017 03:23 
AmiKit

Hi Jan,

True,

But the thing is the failure is that it is the Graphics Adapter setup that is causing the Guru Meditation.
When the installer tries to run C:\GfxCard which is a program that is part of the RunInUAE suit (No idea what it is for) it crashes with a DSI pointing to the memory of the graphics driver. Have you guy's been able to install and run RunInUAE as part of your Beta testing of the Flower Pot development?

Would be interesting to know.
Maybe it will just never work with that specific UAE driver/Wine configuration we are using on the MAC Flower Pot?

Author AmiKit
Admin
#4 Posted: 27 Apr 2017 13:02 
Hi GeoKM, no, I have never tried RunInUAE so I cannot tell what is the problem here.

Flower Pot was built according to general best practice of emulating OS4.1. That means Flower Pot doesn't contain any undocumented feature, it's more or less a well configured WinUAE with few extra OS4 programs wrapped in automated installer with graphical launcher on top

So what you can do to improve the emulation is to replace WinUAE with newer one (http://eab.abime.net/forumdisplay.php?f=5) and/or experiment with its configuration and/or tweak OS4. Or if you believe the crash doesn't happen on real thing, please send a bugreport to Toni Wilen, the developer of WinUAE. The OS4 emulation (compared to OS3.x one) is still in progress.

Author GeoKM
Registered
#5 Posted: 28 Apr 2017 03:36 
Thanks for the response Admin. 8-)

Interestingly, (Although I havn't run it in a while) I am pretty sure that RunInUAE worked when I tried it in my original setup that I build on a Windows box back when WinUAE first started to support PPC and OS4FE Classic came out.

So I thinking its very likely to be Wine related.

It would be great if someone who owns the AmiKit Windows version of FlowerPot could confirm that their OS4 install will install and Run RunInUAE. That would pretty much point to the Wine on MAC environment as the culprit. 8-)

I don't think Toni will be too interested in chasing up a bug against that.

I mean I don't personally care much, I really don't intend to run any 68k stuff or games in the OS4 but it not working does somewhat cripple your product so I just wanted to help you debug it 8-)

Author AmiKit
Admin
#6 Posted: 28 Apr 2017 19:39 
Sure, I can test it as soon as I get home. It's just I am in completely different country right now

Author GeoKM
Registered
#7 Posted: 29 Apr 2017 14:54 
AmiKit

Cool,


So many Countries, in such a small area is Europe...... hehehe Just kidding 8-)

I'm Assuming you're in Europe.


I'm I Australia, So for me other Countries are all a long way off 8-/

Author GeoKM
Registered
#8 Posted: 23 Jun 2017 15:06 
Hi,

Did you have an opportunity to get this on the Widows version of a Flower pot installed AOS 4.1FE?

I guess you've been uber busy with X

No biggy 8-)

I have Mac specific question AmiKit Support Forum / I have Mac specific question / MAC Flower Pot - RunInUAE installer crashing Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0