Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have Linux specific question AmiKit Support Forum / I have Linux specific question /

X-amiga and Amikit

Author tom_a_sparks
Registered
#1 Posted: 28 Sep 2008 08:32 
I am looking at installing X-amiga (http://www.xamiga.net/index.html)
Can i install amikit on top?

Author AmiKit
Admin
#2 Posted: 28 Sep 2008 09:32 
I hope so but I've never tried it... Maybe the author of X-Amiga might provide more help?

Author tom_a_sparks
Registered
#3 Posted: 30 Sep 2008 15:29 
I just get errors
Software failure/recoverable error
uae.log
"
E-UAE 0.8.29-WIP4
Build date: Oct 23 2007 17:20:09
NATMEM: shmget() failed with size 0x08000000. Disabling direct memory access.
Illegal wget at 00f10000
Illegal wget at 00f10002
Illegal wget at 00f10004
Illegal wget at 00f10006
Illegal wget at 00f10008
Illegal wget at 00f1000a
Illegal wget at 00f1000c
Illegal wget at 00f1000e
Illegal wget at 00f10010
Illegal wget at 00f10012
Illegal wget at 00f10014
Illegal wget at 00f10016
Illegal wget at 00f10018
Illegal wget at 00f1001a
Illegal wget at 00f1001c
Illegal wget at 00f1001e
Illegal wget at 00f10020
Illegal wget at 00f10022
Illegal wget at 00f10024
Illegal wget at 00f10026
FS: System starting..
Illegal instruction: 4e7a at 1005a764 -> 1005a770
PTEST @ 10050ace
"

Author tom_a_sparks
Registered
#4 Posted: 1 Oct 2008 06:50 
Software failure
8100 005 task: 1018F398
recoverable error
0100 000F task: 1018F398

Author AmiKit
Admin
#5 Posted: 1 Oct 2008 09:09 
I am sorry but I am afraid I cannot help you. I am not familiar with X-amiga. Please post your report the the author of the X-amiga himself. Thanks.

Author tom_a_sparks
Registered
#6 Posted: 1 Oct 2008 15:46 
i'll report here if I get an updates

Author tom_a_sparks
Registered
#7 Posted: 3 Oct 2008 16:58 
"
I have to finish a project in the next few days, then I'll devote my
time to X-Amiga. It's in need of an update, and I'll have a detailed
look at installing AmiKit at the same time. Hopefully, I might be able
to work out something by next week. If not, remind me!

Amir
"

Author Fractallyte
Registered
#8 Posted: 6 Oct 2008 10:21 Edited by: Fractallyte 
It's OK, no need to remind me

I've confirmed that AmiKit works on X-Amiga (and probably KX Light). I'll detail everything properly in the next few days.

Amir

Author AmiKit
Admin
#9 Posted: 6 Oct 2008 10:35 
Thanks for the info. I would describe your solution in eg. Knowledge Base if you don't mind.

Author tom_a_sparks
Registered
#10 Posted: 7 Oct 2008 04:09 
quoted from Amir (x-amiga)

Edited by Admin: Please don't quote private emails here. Let Amir post the solution himself. Thanks.

Author tom_a_sparks
Registered
#11 Posted: 11 Oct 2008 09:20 Edited by: tom_a_sparks 
my system is 64bit

I tried using the e-uae from amikit
inside of x-amiga (as asked by Amir)

the error I get
/usr/bin/e-uae: line 1: syntax error: "(" unexpected

WTF

Author AmiKit
Admin
#12 Posted: 11 Oct 2008 09:27 
Remind Amir to post the complex solution here

Author tom_a_sparks
Registered
#13 Posted: 11 Oct 2008 09:41 
even the newest version of e-uae for 64bit (http://www.rcdrummond.net/uae/)
has this error?

I have Linux specific question AmiKit Support Forum / I have Linux specific question / X-amiga and Amikit Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 2
Members - 1 [ AmiKit ]
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0