Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have Linux specific question AmiKit Support Forum / I have Linux specific question /

AmiKit on Linux too slow

Author rbrown
Registered
#1 Posted: 30 Jul 2008 22:20 
I'ver been playing with AmiKit Linux RC10 and find it totally unusable because it's dead slow. Tried it with e-uae and uae with the same results. Tried changing everything I can think of and nothing helps. I assume it's not AmiKit that's giving problems because it runs fine under WinUae

Author ness62
Registered
#2 Posted: 31 Jul 2008 17:06 Edited by: ness62 
sniff

Author Slider
Moderator
#3 Posted: 1 Aug 2008 11:12 
I'ver been playing with AmiKit Linux RC10 and find it totally unusable because it's dead slow. Tried it with e-uae and uae with the same results. Tried changing everything I can think of and nothing helps. I assume it's not AmiKit that's giving problems because it runs fine under WinUae

Are you using a 64 bit CPU? If you are then that is the reason AmiKit seems slow. Neither uae or e-uae have JIT available for 64bit and without JIT uae and e-uae can be slow.

If you are not using a 64bit CPU then the problem probably lays with kernel drivers for your hardware not being loaded or the wrong modules being loaded.

Author rbrown
Registered
#4 Posted: 6 Aug 2008 16:17 
I finally got a speeding ticket in AmiKIt under Linux. Maxed out the JIT Translation Buffer setting in EUAE from 0 to 16384 and it now runs supper fast.

Author Andrew Deacon
Registered
#5 Posted: 2 Oct 2008 00:05 
Just come back to Amikit under Ubuntu another go and saw your suggestion about upping the JIT Transalation buffer, like you AMikit runs very slowly with it set to zero. Unfortunately if I set it to anything higher I get a recoverable alert

Any ideas what the problem might be?

Author Andrew Deacon
Registered
#6 Posted: 2 Oct 2008 01:08 
ok, disabled opus and now it works much faster.

Whats the score with MUI in amikit. None of the MUI programs worked they were all looking for muimaster.library. When I installed MUI though it said it was already there.

Anyway its to late to do anymore now.

Cheers

I have Linux specific question AmiKit Support Forum / I have Linux specific question / AmiKit on Linux too slow Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0