AmiKit - Your Modern Retro Experience
  Forums Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0
I have Linux specific question AmiKit Support Forum / I have Linux specific question /  
 

VMWare Ubuntu 11.10 and Amikit - Bad Network

 
Author Unicorn
Guest
#1 Posted: 28 Jan 2012 12:21 
Hi guys,

I am trying to run a VMWare ESXi box, Quad core, 15k Drives and 10GB of Ram. I have then installed Ubuntu 11.10 and got it running happily.

I then installed UAE and copied across a HDF version of Amiga Forever with Amikit 1.5.9 it crashed on startup.

Some quick fiddling noticed that the crash happen at the Auto Updater for Amikit.

Removed Auto Updater and Amikit is running as fast as a real amiga at 1920x1080. Fantastic.

Tried to access the network and it froze again.

2 Days of installing O/S's and UAE has determined the HDF works fine on PCLinuxOS with network running perfectly though screen res limited to 1024x768 due to linux driver instability.

Has anyone run UAE on Ubuntu and used the network?

Is there something I have missed with Amikit and Linux. I see in old documentation bsdsocket.library mentioned but no longer appears in archives.

Author AmiKit
Admin
#2 Posted: 28 Jan 2012 13:39 
In .uaerc configuration file the bsdsocket_emu= is probably set to 'false'. Change it to 'true' otherwise networking will not work on the Amiga side.

http://amikit.amiga.sk/linux.htm

Author Unicorn
Guest
#3 Posted: 28 Jan 2012 14:21 
thanks, found that one.

the config works fine on PCLinuxOS just not Ubuntu???

Interestingly the effect on the OS appears much as bsdsocket false but that could be because the bug kicks in first.

Author Unicorn
Guest
#4 Posted: 29 Jan 2012 12:45 
Has anyone got a suggestion on how to fix this problem with Amikit on Ubuntu.

Or does anyone have a recommended linux install that is either minimal install or fast and efficient larger disrto.

Ubuntu looks so good and is fast on full frame rate of 1 for 1, just no damn network no matter what I try.

Author Unicorn
Guest
#5 Posted: 30 Jan 2012 00:29 
Some additional info, snoopdos shows access eo bsdsocket.library.

I installed fire starter on unbuntu and shows no access from uae.

The failure is somewhere between Amikit and uae or within uae as Ubuntu does not see a network request.

I have Linux specific question AmiKit Support Forum / I have Linux specific question /
 VMWare Ubuntu 11.10 and Amikit - Bad Network

Your Reply Click this icon to move up to the quoted message

 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ Top