AmiKit - Your Modern Retro Experience
  Forums Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0
NEWS AmiKit Support Forum / NEWS /  
 

How is OpenGL Mesa realized in AmiKit? i just tried replicate it for my WinUAE setup.

 
Author RuThaN
Partaker
#1 Posted: 23 Oct 2016 19:30 
Hello,
i Hexen 2 Mesa Amiga port in AmiKit and its running amazing framerate is great 60 FPS, i have tried to replicate it for my WinUAE setup,
good is that 3D Accelerate graphics is running, but framerate is 3-5 FPS, unplayable.

I wonder where is Amikit speed magic?
- I have same WinUAE HW setting, only newer version of WinUAE
- i have only WB 3.1, in Amikit i have 3.9
- i have tried to copy Warp3D files form Amikit library folder
- i have installed AGL * Stormesa - 2015, because main AGL library file wasnt working on my machine - i have got just grey screen.
- i have tried to copy dll Amikits dll to my WinUAE folder

I still have 3-5 FPS, is there any guide how to make OpenGL faster?

Author AmiKit
Admin
#2 Posted: 25 Oct 2016 22:28 
Hmmm.. it seems you have all required files. Are you sure the JIT is enabled in WinUAE settings?
Also, in Libs: there is warp3d.library as well as Warp3D folder, make sure you copied those too.

Author RuThaN
Partaker
#3 Posted: 26 Oct 2016 18:44 
Yes JIT is enabled, i have to enable it after boot, because im using Mac Fusion emulator, which include in start-up sequence something
which is crashing, when JIT enabled during boot. AmigaQuake is running fine, when i enabled JIT later, so it is probably ok.

Libs - yeah i have copied both - warp3d.library and Warp3D folder, only difference is one AGL lib.

I dont fully understand how dll works with WinUAE are they needed for fast OpenGL mesa? Have i somehow enable them, or just copy dll into WinUAE directory?

NEWS AmiKit Support Forum / NEWS /
 How is OpenGL Mesa realized in AmiKit? i just tried replicate it for my WinUAE setup.

Your Reply Click this icon to move up to the quoted message

 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ Top